Home Forums Software ELAN ELAN won't playback video

ELAN won't playback video

This topic contains 5 replies, has 2 voices, and was last updated by  Han 1 week, 3 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
Author Posts
November 21, 2018 at 08:46 #12504

brendon.yoder

I recently removed an old third-party codec pack I had on my computer. Now ELAN won’t playback video files. I get an error message that “No player could be created for <video file>. The format is not supported. quicktime/QTException javax.media.NoPlayerException: Cannot find a player for <video file>”.
My video files are in .mp4 and .MTS formats. Other video players on my computer (Windows Media Player 12, VLC) playback the videos with no problem. I uninstalled and reinstalled ELAN, but continue getting this error message.

ELAN still plays back the audio files in WAV format. I am running ELAN 5.3 on Windows 10.

Any help would be most appreciated. Thank you!

November 21, 2018 at 11:06 #12506

Han

I’m not sure about .mts but .mp4 should run in ELAN without third party codecs.
Does the log (View – View Log…) give more information, especially stemming from a JMMFPlayer (the type of player that should handle .mp4 on Win 10)?

November 23, 2018 at 06:24 #12515

brendon.yoder

Thanks for the reply.

I just checked the log. In attempting to load the .mp4 file, it says it tried to use JDS player and QT Media Player but failed. Then it tried JMF Media Player:

—————-
Using JMF Media Player for file:///C:/Users/…Source1.mp4
current library path:
# a list of many filepaths #
loading windows native libs
Warning: Unable to load a dll or Sharedobject: no jmutil in java.library.path
mediaURL = file:///C:/Users/…Source1.mp4
javax.media.NoPlayerException while creating JMF player
javax.media.NoPlayerException: Cannot find a Player for :file:/C:/Users/…Source1.mp4
at javax.media.Manager.createPlayerForContent(Manager.java:1436)
at javax.media.Manager.createPlayer(Manager.java:441)
at javax.media.Manager.createPlayer(Manager.java:356)
# then follows a long list of additional locations #
—————-

Any additional help you might be able to offer would be most appreciated.

Brendon

November 26, 2018 at 10:41 #12517

Han

The first player to be tried should be the JMMF Player, so with two M’s in the name. I guess there should be some messages of that player before the JDS Player is mentioned?
But then again, if there is such message and it says the file cannot be handled or is not supported, I wouldn’t know what to do about it.
It is always good to try another mp4 file, not from the same collection, to see if that one fails as well.

November 28, 2018 at 12:05 #12527

brendon.yoder

Thanks for the reply. I couldn’t see mention of JMMF Player in the log. I ended up installing a third-party codec pack (K-Lite codec pack) and ELAN again plays .mp4 and files without a problem. The log now says that it uses the JDS player for the .mp4 files.

November 29, 2018 at 11:07 #12533

Han

Strange, I would expect something like
“Using JMMF Player for file:” in the log. Or, if that player cannot be loaded something like this could be in the log:
“JMMF player cannot handle the file: C:\PATH\MMFPlayer.dll : can’t find dependent libraries”.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.