Home Forums Software ELAN Error if trying to open multiple files

Error if trying to open multiple files

This topic contains 10 replies, has 3 voices, and was last updated by  Han 2 days, 11 hours ago.

Viewing 10 posts - 1 through 10 (of 11 total)
Author Posts
Author Posts
January 19, 2018 at 11:08 #11839

angela_

Hello,
when I try to open multiple files, elan gives me the following error message: “the following files were not loaded because of errors in the file”
All of the files as a domain cannot be opened, even though I can open each of them individually.
I am using ELAN 5.1 on an Apple OSX.
Do you have any suggestions?
Thanks, Angela

  • This topic was modified 1 month ago by  angela_.
January 20, 2018 at 16:42 #11845

Han

Yes, some of the multiple file actions are a bit more strict when loading a file than ELAN is when opening a single file.

If you, after having received the mentioned error message, go to View->View Log… there will probably be more information about the problem(s).
E.g. it could be that one or more annotations were found with an end time smaller or equal to the start time.
Do you find more detailed error messages in your log file?

-Han

January 24, 2018 at 11:23 #11851

angela_

Hello,
below you’ll see what the log file looks like (I replaced the username and path).
The “IO error: no protocol: [path/filename]” lists all the files in the
search domain.

Thanks, Angela

————
22.01.2018 16:35:58 mpi.eudico.client.annotator.ELAN main
INFO:

@ELAN Launched

22.01.2018 16:35:58 mpi.eudico.client.annotator.ELAN main
INFO: ELAN 5.1
Java home: /Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
Java version: 1.6.0_65
Runtime: 1.6.0_65-b14-468-11M4833
OS name: Mac OS X
OS version: 10.11.6
OS arch.: x86_64
User language: de
User home: /Users/[username]
User dir: /Applications/ELAN_5.1.app/Contents/Resources
Classpath: /Applications/ELAN_5.1.app/Contents/Java/elan-5.1.jar:/Applications/ELAN_5.1.app/Contents/Java/sunjce_provider.jar:/Applications/ELAN_5.1.app/Contents/Java/help.zip:/Applications/ELAN_5.1.app/Contents/Java/jhall-2.0.0.5.jar:/Applications/ELAN_5.1.app/Contents/Java/nl.mpi.lookup__V1.0.jar
Library path: /Applications/ELAN_5.1.app/Contents/Java:extensions

22.01.2018 16:35:58 mpi.eudico.client.annotator.prefs.PreferencesReader parse
INFO: Reading preferences: /Users/[username]/Library/Preferences/ELAN/elan.pfsx
External updater thread started
Loading new Apple integration 2
22.01.2018 16:35:59 mpi.eudico.client.annotator.prefs.PreferencesReader parse
INFO: Reading preferences: /Users/[username]/Library/Preferences/ELAN/shortcuts1.pfsx
22.01.2018 16:36:08 mpi.eudico.client.annotator.prefs.PreferencesReader parse
INFO: Reading preferences: /Users/[username]/Library/Preferences/ELAN/mf_domains.pfsx
IO error: no protocol: [path/filename]
IO error: no protocol: [path/filename]
IO error: no protocol: [path/filename]
IO error: no protocol: [path/filename]

January 24, 2018 at 14:42 #11852

Han

It’s good that you anonymized the output. Since the error message indicates that there is a problem with constructing or interpreting the location of each file, the [path/filename] parts might be important. Can you confirm that the filenames end with “.eaf” and start with “/”? Does the path look “scrambled”, with special characters not shown correctly?

January 26, 2018 at 12:07 #11859

angela_

Hello,
somehow it is working now, but it may be helpful to others to give some information.
The filenames looked ok (“.eaf” at the end, “/” at the beginning, no strange looking characters).
Two things I realized might have been part of the problem:

1. The .eaf files are located on a server. Even though I was connected to it, ELAN couldn’t load them from the server, but only the local copies on my computer. However, the local copies were only loaded after I addressed the issue below.

2. Some of the .eaf files in the domain contained additional tiers that were coded for other reasons. So, even though most of the tiers were the same in all files, several files had other tiers. Once I deleted some of those additional tiers and copied them to my computer, it worked.

January 26, 2018 at 15:13 #11860

angela_

Correction to my earlier message: it actually was a problem with German umlauts in the [path/filename] part… Sorry for the confusion.

January 29, 2018 at 11:42 #11865

Han

Thanks for the updates. Additional tiers should (indeed) be no problem. But we might have to look into the loading process of the multiple file options (if it is the case that the files with German umlauts can be loaded individually via File-Open).

February 20, 2018 at 05:58 #11901

CAlb

Hello I am experiencing a problem editing multiple files both in 4.9 and 5.1. I get the usual system warning about editing multiple files, but when I accept nothing happens and de facto I can’t work with the ‘edit multiple files’ function. I don’t even get any message from the system. Thank you. CA

  • This reply was modified 3 days, 15 hours ago by  CAlb. Reason: forgot to thank you for your amazing work. Repair on politeness
February 20, 2018 at 11:30 #11903

Han

Hi, just to be sure: after the steps you described, you clicked the Load Domain button and tried to load a non-empty domain or a set of .eaf files selected in a the file browser? And then nothing happens, not even an error message?
Maybe, after these steps, there is information in the log file (View->View Log…)?

February 20, 2018 at 12:51 #11904

CAlb

Hi. Thank you for your answer, I checked. Yes the domains are loaded but to be sure I deleted them and re-built from scratch.

I checked the log and I think the error boils down to this line (in version 5.1)

Exception in thread “AWT-EventQueue-0” mpi.eudico.server.corpora.clomimpl.abstr.ParseException: /Users/claudia/Library/Preferences/ELAN/ISO-639-3-Languages.xml (No such file or directory)

so it’s my system. I downloaded yesterday the 5.1. because I was experiencing troubles on 4.9. But now the multiple edit works on 4.9. Sorry for alarming you for nothing. Thank you again.

Viewing 10 posts - 1 through 10 (of 11 total)

You must be logged in to reply to this topic.