Home Forums Software ELAN Installing ELAN 5.1 in Ubuntu 17.10

Installing ELAN 5.1 in Ubuntu 17.10

Tagged: , ,

This topic contains 7 replies, has 3 voices, and was last updated by  pehkawn 3 weeks, 5 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
Author Posts
Author Posts
March 17, 2018 at 20:19 #12095

pehkawn

I’m currently trying to install ELAN 5.1 on Ubuntu 17.10. I did so according to the following steps:

  1. The install page states that the software requires Java Runtime Environment, which I installed prior to installing ELAN from Oracle’s Java pages, following their instructions.
  2. I then dowloaded the .bin file and then ran the installation from terminal (./ELAN_5-1_linux.bin).
  3. A graphical UI pops up, and I just followed the instructions and installed ELAN to my home folder, seemingly without problems.
  4. I ran the program (./ELAN_5.1 inside the folder), but it won’t start. However, I get the following output:

raw jre dir: /usr/lib/jvm/java-8-openjdk-amd64/jre/
jre dir: /usr/lib/jvm/java-8-openjdk-amd64/jre/
LD_LIBRARY_PATH: /home/user/ELAN_5.1/jmf__Vlin2.1.1fcs:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/i386:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/i386/xawt:/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/i386/client:
LD_PRELOAD:

Then nothing happens. No error messages, just returns to command line. I did however notice some anomaly: There is <b>no i386 folder</b> inside /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/. The paths


/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/i386
/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/i386/xawt
/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/i386/client

therefore does not exist. I assume failure to add the correct paths to LD_LIBRARY_PATH may be related to the failure to start ELAN. ..and shouldn’t LD_PRELOAD be followed by a path?

Any input on what is causing the issue and how to solve it is much appreciated.

  • This topic was modified 1 month ago by  pehkawn. Reason: Error in formatting. Forum does not support bold letters
March 19, 2018 at 10:46 #12098

Han

I checked on the Ubuntu system I have available here (16.10) and on which ELAN runs. This is the JRE dir:
/usr/lib/jvm/java-8-oracle/jre/
and in the LD_LIBRARY_PATH I also see a i386 folder, which in fact does not exist. There is nothing after LD_PRELOAD here either. Nevertheless ELAN starts, so maybe that missing folder is not a/the problem.
Is there a .elan_data folder in your home folder and is there a file named elan0.log? If so, are there error messages in that log file that might be useful?

March 19, 2018 at 10:58 #12100

pehkawn

I just checked. There is currently no folder named .elan_data. When I try run ELAN, it keeps working a few seconds after LD_PRELOAD appears, then returns to prompt. I don’t know if this is helpful.

  • This reply was modified 1 month ago by  pehkawn. Reason: Additional information
March 20, 2018 at 10:30 #12103

Han

Thanks. I was wondering if ELAN maybe launched and immediately crashed when creating the first window, but in that case there would be the .elan_data folder (that’s one of the first things that ELAN does).
The only thing I can think of now is that there might be some problem with the launch script. So, you could try to launch ELAN directly, with the java command on the command line. Assuming that you get some output if you open a Terminal window and type java -version, you could try the following:

– from the ELAN folder, open the file ELAN_5.1.lax in a text editor
– in a Terminal window cd to the ELAN folder
– type java -cp
– copy and paste everything to the right of the “=” sign of the lax.class.path line from the .lax file to the terminal, followed by a space
– copy and paste everything to the right of the “=” sign of the lax.nl.java.option.additional line from the .lax file to the terminal, followed by a space
– copy and paste everything to the right of the “=” sign of the lax.main.class line from the .lax file to the terminal, followed by Enter

Does this work?

March 20, 2018 at 13:07 #12105

pehkawn

I followed your instruction, but I am still unable to load ELAN.
I entered the following in Terminal

~/ELAN_5.1$ java -cp lib/elan-5.1.jar:lib/jhall-2.0.0.5.jar:lib/help.zip:jmf__Vlin2.1.1fcs/jmf.jar:jmf__Vlin2.1.1fcs/fobs4jmf.jar:lax.jar -Djava.util.logging.config.file=elanlog.properties -Djava.ext.dirs=/home/user/ELAN_5.1/ext -Djava.library.path=/home/user/ELAN_5.1/lib -Dswing.aatext="true" -Dsun.net.client.defaultConnectTimeout=-1 mpi.eudico.client.annotator.ELAN

and got the following output:

Can't load log handler "mpi.eudico.util.ErrOutLogFileHandler"
java.io.FileNotFoundException: /home/user/.elan_data/elan29.log (Fila eller mappa finnes ikke)
java.io.FileNotFoundException: /home/user/.elan_data/elan29.log (Fila eller mappa finnes ikke)
at java.io.RandomAccessFile.open0(Native Method)
at java.io.RandomAccessFile.open(RandomAccessFile.java:316)
at java.io.RandomAccessFile.<init>(RandomAccessFile.java:243)
at mpi.eudico.util.ErrOutLogFileHandler.openFile(ErrOutLogFileHandler.java:475)
at mpi.eudico.util.ErrOutLogFileHandler.initHandler(ErrOutLogFileHandler.java:266)
at mpi.eudico.util.ErrOutLogFileHandler.<init>(ErrOutLogFileHandler.java:128)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:423)
at java.lang.Class.newInstance(Class.java:442)
at java.util.logging.LogManager$5.run(LogManager.java:966)
at java.security.AccessController.doPrivileged(Native Method)
at java.util.logging.LogManager.loadLoggerHandlers(LogManager.java:958)
at java.util.logging.LogManager.initializeGlobalHandlers(LogManager.java:1578)
at java.util.logging.LogManager.access$1500(LogManager.java:145)
at java.util.logging.LogManager$RootLogger.accessCheckedHandlers(LogManager.java:1667)
at java.util.logging.Logger.getHandlers(Logger.java:1777)
at java.util.logging.Logger.log(Logger.java:735)
at java.util.logging.Logger.doLog(Logger.java:765)
at java.util.logging.Logger.log(Logger.java:788)
at java.util.logging.Logger.info(Logger.java:1490)
at mpi.eudico.client.annotator.ELAN.main(ELAN.java:63)

@ELAN Launched

External updater thread started
Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: Could not initialize class mpi.eudico.client.annotator.util.SystemReporting
at mpi.eudico.client.annotator.commands.global.MenuAction.<clinit>(MenuAction.java:34)
at mpi.eudico.client.annotator.ElanFrame2.initMenuBar(ElanFrame2.java:1178)
at mpi.eudico.client.annotator.ElanFrame2.initFrame(ElanFrame2.java:1060)
at mpi.eudico.client.annotator.ElanFrame2.<init>(ElanFrame2.java:298)
at mpi.eudico.client.annotator.FrameManager.createEmptyFrame(FrameManager.java:756)
at mpi.eudico.client.annotator.ELAN$2.run(ELAN.java:127)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:80)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Seemingly it fails to find some essentila filer or folder. Hope the posted message i helpful.

March 20, 2018 at 15:56 #12107

Han

It is helpful, but it is still strange. The first error we could probably get rid of by removing the -D option concerning logging, but then there is the next error message about a class not being found. The mentioned classes should all be in the same elan-5.1.jar file (from which some classes loaded successfully).
What is the size of that .jar, in Kb?
If you do a jar -tvf lib/elan-5.1.jar command, are the mentioned classes listed (as far as you can tell, the dots will be replaced by forward slashes)?

March 24, 2018 at 14:34 #12115

lucien

Dear pehkawn, I encountered a similar issue when I upgraded from debian 8 to debian 9.
I do not remember how I searched it, but finally I resolved this issue disabling gnome assistive technologies. In order to do so, just comment out (adding #) the following line in the file /etc/java-8-openjdk/accessibility.properties . You will end up with :
#assistive_technologies=org.GNOME.Accessibility.AtkWrapper

I did the same in /usr/lib/jvm/java-8-openjdk-amd64/jre/lib/accessibility.properties as I was not sure which one was relevant (I think one is writing the other). It works with the former only.
ELAN launches fine after this.
Just try this workaround maybe.

March 26, 2018 at 11:30 #12118

pehkawn

Thank you for your reply, lucien. I have no idea what implications it will have to comment out that line, but it worked!

It was not necessary to change
/usr/lib/jvm/java-8-openjdk-amd64/jre/lib/accessibility.properties, as it was a symlink to
/etc/java-8-openjdk/accessibility.properties.

I haven’t really tested if there are other issues in the program yet, but I am at least now able to start ELAN.

  • This reply was modified 3 weeks, 5 days ago by  pehkawn. Reason: Added a sentence. Fixed formatting for better readability
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.