Home Forums Software ELAN Issue with video in ELAN

Issue with video in ELAN

Tagged: 

This topic contains 13 replies, has 3 voices, and was last updated by  Han 2 days, 17 hours ago.

Viewing 10 posts - 1 through 10 (of 14 total)
Author Posts
Author Posts
January 28, 2019 at 11:11 #12685

soso83

Hello,

If I play the media in ELAN the image get blocked after 1-2 seconds but the sound still playing. Do you know why?

I played in an other software and it works. I thoughts maybe would be the memories and I deleted almost everything that I have on my pc and it still not work. Thank you for your help

January 28, 2019 at 15:59 #12687

Han

Can you add some more information on the type of media file, the version of ELAN and the version of the operating system (Windows I guess)?
And can you have a look in the log (View->View Log…) if there are meaningful (error) messages that could be related to this problem?

-Han

January 29, 2019 at 20:16 #12721

soso83

Hello,

the media file is mp4 and the operating system is mac.

In the log is it written : 29.01.19 20:20:24.759 ELAN_5.4-AVFX[783]: AVF error: Perf capability check failed: 0xe00002be.

Do you need more informations?

Best regards,

Sabrine

January 29, 2019 at 20:18 #12722

soso83

The version of ELAN is Test: ELAN 5.4 with AVFoundation player and JavaFX player

January 31, 2019 at 09:16 #12723

Han

Thanks for reporting this problem with the test version. I would be interested in the complete log, maybe there are some more useful clues in it. You don’t have to post it here, but could send it to me (han.sloetjes AT mpi.nl).

In that version there is an alternative player for mp4. Go to Edit->Preferences->Edit Preferences ->Platform/OS tab, select the JavaFX Media Framework radio button, click Apply and open the file again.
You can verify which player is in use by right-clicking the video and selecting Player Info.

-Han

February 6, 2019 at 19:14 #12735

meziza

Hi,

I am also facing difficulty with video on Elan 5.4 (standard not Test version) on Windows 10. The mp4 video (which otherwise runs fine on VLC or other programmes) stopped playing and shows only a blue display with some background noise.

I am happy to forward you the logs.

Yours truly,
Anton

February 7, 2019 at 10:13 #12738

Han

Yes, you may send the logs to me, it is difficult to tell what is going on without further information.
It sounds like video in ELAN 5.4 worked for some time but now doesn’t anymore? Or that this video plays up to a certain point and then stopped?
I assume it is not a matter of resizing the media area to get the video display correctly again?

-Han

February 7, 2019 at 14:33 #12740

meziza

Hi again and thanks a lot for your prompt response.

Indeed, the video worked for sometime when I was still using 5.3 version and then it just stopped. I tried with other .mp4 videos and tried reinstalling ELAN (several times), still same blue screen and nothing plays. At the same time .wav files extracted from the same videos work just fine.

Resizing the video is not the issue as well.

Here are the full logs when I open one of the .eaf projects that I have worked on before:

Feb 07, 2019 1:28:11 PM mpi.eudico.client.annotator.ELAN main
INFO:

@ELAN Launched

Feb 07, 2019 1:28:12 PM mpi.eudico.client.annotator.ELAN main
INFO: ELAN 5.4
Java home: C:\Program Files (x86)\ELAN 5.4\jre
Java version: 1.7.0_60
Runtime: 1.7.0_60-b19
OS name: Windows 8.1
OS version: 6.3
OS arch.: x86
User language: en
User home: C:\Users\meziza
User dir: C:\Program Files (x86)\ELAN 5.4
Classpath: C:\Program Files (x86)\ELAN 5.4\lib\elan-5.4.jar;C:\Program Files (x86)\ELAN 5.4\lib\help.zip;C:\Program Files (x86)\ELAN 5.4\lib\jhall-2.0.0.5.jar;C:\Program Files (x86)\ELAN 5.4\jmf2.1.1a\jmf.jar;C:\Program Files (x86)\ELAN 5.4\lax.jar;
Library path: C:\Program Files (x86)\ELAN 5.4\jre\bin;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files (x86)\Common Files\SIL;C:\Program Files (x86)\SIL\FieldWorks 8\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\System32\OpenSSH\;C:\Program Files (x86)\Common Files\Enchant\;C:\Users\meziza\AppData\Local\Microsoft\WindowsApps;;.
Display info:
Screen 1 – isDefault:true, w:1920, h:1080, bitDepth:32
Main screen resolution:120 (w:1920, h:1080)

Feb 07, 2019 1:28:12 PM mpi.eudico.client.annotator.prefs.PreferencesReader parse
INFO: Reading preferences: C:\Users\meziza\.elan_data\elan.pfsx
External updater thread started
Feb 07, 2019 1:28:12 PM mpi.eudico.client.annotator.prefs.PreferencesReader parse
WARNING: Preferences file does not exist: C:\Users\meziza\.elan_data\shortcuts.pfsx
Feb 07, 2019 1:28:12 PM mpi.eudico.client.annotator.commands.ShortcutsUtil readCurrentShortcuts
INFO: Could not load the keyboard shortcut preferences file. The file does not exist or is not valid.
Feb 07, 2019 1:28:12 PM mpi.eudico.client.annotator.prefs.PreferencesReader parse
INFO: Reading preferences: C:\Users\meziza\Desktop\Parsi_working_folder\ELAN\parsi_funeral004\26.10\parsi_funeral004.pfsx
Using JMMF Player for file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.mp4
Using JDS Player for file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Registered Filters:
0: WMAudio Decoder DMO
1: WMAPro over S/PDIF DMO
2: WMSpeech Decoder DMO
3: MP3 Decoder DMO
4: Mpeg4s Decoder DMO
5: WMV Screen decoder DMO
6: WMVideo Decoder DMO
7: Mpeg43 Decoder DMO
8: Mpeg4 Decoder DMO
9: DV Muxer
10: Color Space Converter
11: WM ASF Reader
12: AVI Splitter
13: VGA 16 Color Ditherer
14: SBE2MediaTypeProfile
15: Microsoft DTV-DVD Video Decoder
16: AC3 Parser Filter
17: StreamBufferSink
18: MJPEG Decompressor
19: MPEG-I Stream Splitter
20: SAMI (CC) Parser
21: VBI Codec
22: MPEG-2 Splitter
23: Closed Captions Analysis Filter
24: SBE2FileScan
25: Microsoft MPEG-2 Video Encoder
26: Internal Script Command Renderer
27: MPEG Audio Decoder
28: DV Splitter
29: Video Mixing Renderer 9
30: Microsoft MPEG-2 Encoder
31: ACM Wrapper
32: Video Renderer
33: MPEG-2 Video Stream Analyzer
34: Line 21 Decoder
35: Video Port Manager
36: Video Renderer
37: VPS Decoder
38: WM ASF Writer
39: VBI Surface Allocator
40: File writer
41: DVD Navigator
42: Overlay Mixer2
43: AVI Draw
44: Microsoft MPEG-2 Audio Encoder
45: WST Pager
46: MPEG-2 Demultiplexer
47: DV Video Decoder
48: SampleGrabber
49: Null Renderer
50: MPEG-2 Sections and Tables
51: Microsoft AC3 Encoder
52: StreamBufferSource
53: Smart Tee
54: Overlay Mixer
55: AVI Decompressor
56: AVI/WAV File Source
57: Wave Parser
58: MIDI Parser
59: Multi-file Parser
60: File stream renderer
61: Microsoft DTV-DVD Audio Decoder
62: StreamBufferSink2
63: AVI Mux
64: Line 21 Decoder 2
65: File Source (Async.)
66: File Source (URL)
67: Infinite Pin Tee Filter
68: Enhanced Video Renderer
69: BDA MPEG2 Transport Information Filter
70: MPEG Video Decoder

Filters in the filter chain: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Filter 1: Default DirectSound Device
Pin 1: Audio Input pin (rendered)
Filter 2: Wave Parser
Pin 1: output
Pin 2: input pin
Filter 3: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Pin 1: Output
MediaUrl SignalViewer: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Feb 07, 2019 1:28:13 PM mpi.eudico.client.annotator.commands.ExportMediaCA <init>
INFO: No version of M2-edit-cl or M2-xcode-cl found
Feb 07, 2019 1:28:13 PM mpi.eudico.client.annotator.commands.ClipMediaCA <init>
INFO: Found clipping script: clip-media.txt
Feb 07, 2019 1:28:13 PM mpi.eudico.client.annotator.tiersets.TierSetUtil readTierSetsFromFile
INFO: Could not load the tier set file. The file does not exist or is not valid.
Feb 07, 2019 1:28:14 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in analyzer-gloss-0.4.jar
Feb 07, 2019 1:28:14 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in annotyzer-lexicon-0.4-compound.jar
Feb 07, 2019 1:28:14 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in annotyzer-whitespace-split-0.7.jar
Feb 07, 2019 1:28:15 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 07, 2019 1:28:15 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 07, 2019 1:28:15 PM mpi.eudico.client.annotator.prefs.PreferencesWriter encodeAndSave
INFO: Writing preferences: C:\Users\meziza\.elan_data\elan.pfsx
Feb 07, 2019 1:28:15 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 07, 2019 1:33:15 PM mpi.eudico.server.corpora.clomimpl.dobes.EAF30Encoder save
INFO: C:\Users\meziza\Desktop\Parsi_working_folder\ELAN\parsi_funeral004\26.10\parsi_funeral004.eaf.001 <—- XML output – EAF version: 3.0

Feb 07, 2019 1:38:15 PM mpi.eudico.server.corpora.clomimpl.dobes.EAF30Encoder save
INFO: C:\Users\meziza\Desktop\Parsi_working_folder\ELAN\parsi_funeral004\26.10\parsi_funeral004.eaf.001 <—- XML output – EAF version: 3.0

February 11, 2019 at 10:56 #12745

Han

The relevant messages in the log concern the width and height of the video, which could not be retrieved:
….JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
This has been reported by other users as well, but it is unclear what the cause could be. In your case, it is strange that video worked for a long time and then suddenly not anymore. Something must have happened, something must have changed in the meantime, it would be good to be able to link the problem to some event.

In the ELAN installation folder, there is a text file “elan.properties”. If you open that file you’ll find somewhere a line:
JMMFDebug=false
You could set this to true, launch ELAN again try again and see if there are additional error messages in the log?

February 11, 2019 at 14:58 #12754

meziza

Thanks a lot for the reply. I am trying to recall what other programmes or updates have I installed around that time, but it was nothing apart from SIL’s Keyman and Google Input. The latter caused some changes in the registry, but I bout it could have any impact on any of the video tools.

Following you advice, I have changed:

##Debug mode for the Java-Microsoft Media Foundation media player (Windows)
JMMFDebug=true

The issue, however, remained unresolved. Here is the log:

Filters in the filter chain: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Filter 1: Default DirectSound Device
Pin 1: Audio Input pin (rendered)
Filter 2: Wave Parser
Pin 1: output
Pin 2: input pin
Filter 3: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Pin 1: Output
MediaUrl SignalViewer: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Feb 11, 2019 2:01:48 PM mpi.eudico.client.annotator.commands.ExportMediaCA <init>
INFO: No version of M2-edit-cl or M2-xcode-cl found
Feb 11, 2019 2:01:48 PM mpi.eudico.client.annotator.commands.ClipMediaCA <init>
INFO: Found clipping script: clip-media.txt
Feb 11, 2019 2:01:48 PM mpi.eudico.client.annotator.tiersets.TierSetUtil readTierSetsFromFile
INFO: Could not load the tier set file. The file does not exist or is not valid.
Feb 11, 2019 2:01:49 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in analyzer-gloss-0.4.jar
Feb 11, 2019 2:01:50 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in annotyzer-lexicon-0.4-compound.jar
Feb 11, 2019 2:01:50 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in annotyzer-whitespace-split-0.7.jar
Feb 11, 2019 2:01:51 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 11, 2019 2:01:51 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 11, 2019 2:01:51 PM mpi.eudico.client.annotator.prefs.PreferencesWriter encodeAndSave
INFO: Writing preferences: C:\Users\meziza\.elan_data\elan.pfsx
Feb 11, 2019 2:01:51 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 11, 2019 2:02:02 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet

Viewing 10 posts - 1 through 10 (of 14 total)

You must be logged in to reply to this topic.