Home Forums Software ELAN Issue with video in ELAN

Issue with video in ELAN

Tagged: 

This topic contains 16 replies, has 3 voices, and was last updated by  meziza 2 months ago.

Viewing 7 posts - 11 through 17 (of 17 total)
Author Posts
Author Posts
February 11, 2019 at 15:04 #12755

meziza

P.S. Can it be an anti-virus issue?

February 12, 2019 at 10:31 #12759

Han

I doubt this last suggestion, but one never knows. Are there any errors or warnings in the systems EventViewer that might relate to the video playback?

Moreover: did you relaunch ELAN after changing the Debug setting? There should be many more message in the log (lines starting with “MMFPlayer Info” etc.).
What you can also try is to switch to “synchronous mode”, to see if that makes a difference (Edit->Preferences->Edit Preferences->Platform/OS->Synchronous interaction with the player).

If nothing works, you could also try the testing version of ELAN, 5.4-FX, and see if the JavaFX player works?

February 14, 2019 at 13:00 #12767

meziza

Thanks a lot again for your follow up!

EventViewer has nothing related to ELAN either in Errors or in Warnings. I can check again if you tell me if there is a specific folder to look at.

Tried switching on Synchronous interaction, sadly, no result.

As for your other suggestion, unlike ELAN 5.4 I cannot install the FX version. The error message is as follows: “Setup was unable to create the directory… ERROR 5: Acces is denied”. Is I manually create a folder with the same name as the setup suggests and try to install there the error message is as follows: “CreateFile failed; code 5. Access is denied”. Maybe this is part of the problem? Is there a way to solve this?

Finally, indeed, I have relaunched ELAN. the log provides only following messages:

Filters in the filter chain: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Filter 1: Default DirectSound Device
Pin 1: Audio Input pin (rendered)
Filter 2: Wave Parser
Pin 1: output
Pin 2: input pin
Filter 3: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Pin 1: Output
MediaUrl SignalViewer: file:///C:/Users/meziza/Desktop/Parsi_working_folder/4_trimming_extracting/parsi_funeral004.wav
Feb 14, 2019 12:03:19 PM mpi.eudico.client.annotator.commands.ExportMediaCA <init>
INFO: No version of M2-edit-cl or M2-xcode-cl found
Feb 14, 2019 12:03:19 PM mpi.eudico.client.annotator.commands.ClipMediaCA <init>
INFO: Found clipping script: clip-media.txt
Feb 14, 2019 12:03:19 PM mpi.eudico.client.annotator.tiersets.TierSetUtil readTierSetsFromFile
INFO: Could not load the tier set file. The file does not exist or is not valid.
Feb 14, 2019 12:03:20 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in analyzer-gloss-0.4.jar
Feb 14, 2019 12:03:20 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in annotyzer-lexicon-0.4-compound.jar
Feb 14, 2019 12:03:20 PM mpi.eudico.client.annotator.util.AvailabilityDetector detectFromJar
WARNING: No plug-in cmdi metadata file found in annotyzer-whitespace-split-0.7.jar
Feb 14, 2019 12:03:22 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 14, 2019 12:03:22 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 14, 2019 12:03:22 PM mpi.eudico.client.annotator.prefs.PreferencesWriter encodeAndSave
INFO: Writing preferences: C:\Users\meziza\.elan_data\elan.pfsx
Feb 14, 2019 12:03:22 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet
Feb 14, 2019 12:03:24 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer$InitWaitThread run
INFO: JMMFMediaPlayer: Init Session
Feb 14, 2019 12:03:24 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer$InitWaitThread run
INFO: Aspect Ratio: 0.0
Feb 14, 2019 12:03:24 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer$InitWaitThread run
INFO: Duration: 1131467
Feb 14, 2019 12:03:24 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer$InitWaitThread run
INFO: Time per frame: 33.333333333333336
Feb 14, 2019 12:03:24 PM mpi.eudico.client.annotator.player.JMMFMediaPlayer getSourceWidth
WARNING: Width not initialized yet

February 19, 2019 at 11:50 #12768

Han

Ok, thanks, so some information is detected correctly (?) from the .mp4 file, but not the width and height of the video. I have no clue, no idea why this doesn’t work.

Did you already try to install the FX version somewhere outside of “Program Files”? It seems there is still an issue with permissions, maybe this can be solved by installing somewhere else?

February 26, 2019 at 18:39 #12777

meziza

Yes, tried installing to a different folder. In admin mode as well, unfortunately, same result.

Is there anything else I can try with the video? At least to understand what causes this annoying issue.

February 27, 2019 at 10:13 #12778

Han

Strange that the installation of the FX version does not work. If you want, you can run the installer from the command line with a “/LOG” parameter. It should create a log file in your TEMP folder (or use /LOG=”filename” to specify a location for the log). Maybe the information in the log explains why “CreateFile” fails. Speaking of the TEMP folder: it might be that the installer uses a temporary folder for unpacking and that that part fails, I don’t know.
I read that sometimes anti virus software blocks creation of a file or folder.

Maybe it’s worth trying to re-encode the mp4? Especially if the settings of your .mp4 file are very different from the recommendations in this guide.

May 16, 2019 at 22:28 #12960

meziza

Hi!

After I installed the latest 5-6 FX update,
video started working again!

Thanks a lot for your support

Viewing 7 posts - 11 through 17 (of 17 total)

You must be logged in to reply to this topic.