Home Forums Software ELAN Media Navigation on Linux

Media Navigation on Linux

This topic contains 1 reply, has 2 voices, and was last updated by  Han 1 week, 3 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
Author Posts
Author Posts
November 27, 2018 at 19:48 #12524

patrickL9887

Fairly new to Linux – ELAN won’t properly navigate through my media frame-by-frame.

If I use the shortcut key to navigate frame by frame, the cross hair either does not move or it jumps forward and backward, etc. If I manually click on the Frame-forward button, the crosshair moves, but the video player does not change.

I’ve seen older posts that discuss this issue, but I cannot seem to find a real solution (I’m running Ubuntu 16.04 LTS)

I have tried:
-Different versions of Elan (5.2, 5.3 and 5.0) for linux
-different media files – .mov, .mpeg, .mp4
-changing the media framework between VLC player library and Java media framework

Any tips would be warmly welcome!

November 29, 2018 at 10:04 #12531

Han

Yes, there are several issues with ELAN on Linux and media playback is a major one (see remarks on this in the file “Media Playback Read Me.txt”).
In any case, I would expect the frame navigation by keyboard shortcuts to be the same as navigation by button clicks. But I would have to verify this. Apart from that, there’s not much we can do at the moment if the playback and/or media navigation is insufficient. Integration of another media player, e.g. based on (J)FFmpeg, is a lot of work.

I’m not sure if you also tried the beta version which includes a JavaFX media player? It has several issues as well, but it could be that frame navigation there works if you have i-frame-only (or key-frame-only) mp4 files. So far this has mainly be tested on macOS (maybe I can devote some time to the Linux version of ELAN in December).

-Han

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.