Home Forums Software ELAN Mismatching cveids after ECV update

Mismatching cveids after ECV update

This topic contains 2 replies, has 2 voices, and was last updated by  Matt Brown 5 days, 8 hours ago.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
December 3, 2018 at 15:28 #12541

Matt Brown

Hi there, can anyone advise?

We are trying to update an ECV which is referenced by a large number of EAFs. As an example, the ECV used to look something like this:

HAM (cveid0)
EGGS (cveid1)
BACON (cveid2)

After the change, the ECV now looks something like this:

HAM (cveid_very_long_hex_string)
FRIED_EGGS (cveid_very_long_hex_string)
SCRAMBLED_EGGS (cveid_very_long_hex_string)
POACHED_EGGS (cveid_very_long_hex_string)
BACON (cveid_very_long_hex_string)

Updating the ECV (and using the new Apply template to multiple EAFs) seems to work correctly in that the new ECV is registered. But existing annotations now have the “wrong” cveid – e.g. HAM annotations are still referenced as cveid0 even though the new references is different.

My question is, does this matter? Will it cause any issues?

December 4, 2018 at 15:01 #12542

Han

In principle this doesn’t matter, there will only be issues in very special situations (see below at *). But it might be good to run the Multiple File “Update Transcriptions for ECVs” with the option “Don’t change the annotation value but update the reference to a corresponding CV entry instead” selected.
If this is the preferred behavior you could also tick the option “After changes in an ECV, don’t update the annotation value but update the reference to a CV entry” in the pane Edit Preferences->CV.
The default behavior is the other way round, see below also.

*) If you would later edit the ECV in an XML editor (or an old version of ELAN) and would add e.g. an entry:

JAM(cveid0)

and would then open an existing .eaf file with an annotation with value HAM(CVE_REF=”cveid0″), ELAN would update the value based on the reference, so HAM would become JAM (unless the option mentioned above has been set).

-Han

December 4, 2018 at 16:57 #12543

Matt Brown

Many thanks, Han – understood.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.