Home Forums Software ELAN opening existing document in ELAN 3.0

opening existing document in ELAN 3.0

This topic contains 5 replies, has 3 voices, and was last updated by  Claire Bowern 11 years, 10 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
Author Posts
March 8, 2007 at 03:02 #5096

Tarcísio Leite

Dear all,
After installing the new version of ELAN, I’ve tried to open some existing documents of mine several times (documents which I still can perfectly open with ELAN 2.6.3) but the same problem happens: I’ve got an ELAN blank page, with no transcriptions/tiers/linguist types/controlled vocabulary at all, and no linked video files either. I tried to add the video files in the menu option “Linked files – Add”, but I was only able to get the videos… transcriptions and the file structure still don’t appear.
I took a look at the updated manual but saw no changes in this respect, so I’m wondering what am I doing wrong?
Best,
Tarcísio (USP-Brazil)

March 14, 2007 at 11:50 #6283

Han

There can be problems with opening ELAN files if the path contains accented characters (e.g. ç, ã, ü). ELAN 3.0 uses a newer version of a library to ‘parse’ the .eaf files and this seems to explain the different behavior compared to ELAN 2.6.3.
We’ll see if there is anything that we can do to fix this problem in a next release.

Han

March 31, 2007 at 16:13 #6284

Anika Falkert

Same problem here: no way to open an existing ELAN-Document (under OS 10.4.9, PPC). There are no special characters neither in the path nor in the title. (The .eaf files have been created by EXMARALDA

April 2, 2007 at 09:30 #6285

Han

The only way to find out what is going on then is to have a look in the log file.
After trying to open such file perform next steps:

open a Terminal window and do:
cd .elan_data
ls -al
locate the most recent elan.log (elan0.log or elan1.log) and then:
cat elan0.log

Copy the output and post it here or mail it to me.

Han

April 2, 2007 at 17:44 #6286

Anika Falkert

Hi Han,
that’s what I get from the log file:

2 avr. 2007 17:42:52 mpi.eudico.client.annotator.ELAN main
INFO: ELAN 3.0.0
2 avr. 2007 17:42:53 mpi.eudico.client.annotator.ELAN main
INFO: Java version: 1.5.0_07
2 avr. 2007 17:42:53 mpi.eudico.client.annotator.ELAN main
INFO: Runtime version: 1.5.0_07-164
2 avr. 2007 17:42:53 mpi.eudico.client.annotator.util.SystemInstallationSecurity verifyLibExt
INFO: verifying lib/ext /USERS/AFA/LIBRARY/JAVA/EXTENSIONS
2 avr. 2007 17:42:53 mpi.eudico.client.annotator.integration.ExternalLauncher start
INFO: External launch thread started…
[Error] GE01el.eaf:2:67: cvc-datatype-valid.1.2.1: ” is not a valid value for ‘dateTime’.
[Error] GE01el.eaf:2:67: cvc-attribute.3: The value ” of attribute ‘DATE’ on element ‘ANNOTATION_DOCUMENT’ is not valid with respect to its type, ‘dateTime’.
[Error] GE01el.eaf:2:67: cvc-complex-type.3.1: Value ‘2.1’ of attribute ‘FORMAT’ of element ‘ANNOTATION_DOCUMENT’ is not valid with respect to the corresponding attribute use. Attribute ‘FORMAT’ has a fixed value of ‘2.4’.
[Error] GE01el.eaf:7:48: cvc-datatype-valid.1.2.1: ‘NaN’ is not a valid value for ‘integer’.
[Error] GE01el.eaf:7:48: cvc-attribute.3: The value ‘NaN’ of attribute ‘TIME_VALUE’ on element ‘TIME_SLOT’ is not valid with respect to its type, ‘unsignedInt’.
java.lang.NumberFormatException: For input string: “NaN”
at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
at java.lang.Long.parseLong(Long.java:403)
at java.lang.Long.parseLong(Long.java:461)
at mpi.eudico.server.corpora.clomimpl.dobes.ACM24TranscriptionStore.loadTranscription(ACM24TranscriptionStore.java:364)
at mpi.eudico.server.corpora.clomimpl.abstr.TranscriptionImpl.initialize(TranscriptionImpl.java:326)
at mpi.eudico.server.corpora.clomimpl.abstr.TranscriptionImpl.
(TranscriptionImpl.java:198)
at mpi.eudico.client.annotator.ElanFrame2.openEAF(ElanFrame2.java:304)
at mpi.eudico.client.annotator.ElanFrame2.openEAF(ElanFrame2.java:361)
at mpi.eudico.client.annotator.FrameManager.createFrame(FrameManager.java:572)
at mpi.eudico.client.annotator.commands.global.OpenMA.actionPerformed(OpenMA.java:93)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1882)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2202)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:420)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:258)
at javax.swing.AbstractButton.doClick(AbstractButton.java:334)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1000)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1041)
at java.awt.Component.processMouseEvent(Component.java:5554)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
at java.awt.Component.processEvent(Component.java:5319)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4021)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3869)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3936)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1774)
at java.awt.Component.dispatchEvent(Component.java:3869)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Best regards,
afa

April 28, 2007 at 22:44 #6287

Claire Bowern

I have the same problem, although my files are Elan 3.0 files. I just switched from a Dell Latitude D600 to a Vaio

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.