Home Forums Software ELAN Play selection jumps to the end of the media file

Play selection jumps to the end of the media file

This topic contains 5 replies, has 2 voices, and was last updated by  Han 9 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
Author Posts
Author Posts
February 5, 2018 at 15:54 #11872

JS

Hello!

I have a problem with the “Play selection” button. I updated ELAN to 5.1 version, QuickTime and also my Java, still, whenever I mark a segment that should be played the cursor doesn’t stop at the offset but goes all the way back to the end of the ELAN file. What can I do about it?

Everything worked perfectly a month ago and no, there are no system changes or bigger updates on the Win 8 that I’m using.

The video is 1280×720, 50frs/s

Any hints/solutions/recommendations are more than welcome

J.

  • This topic was modified 9 months, 2 weeks ago by  JS.
February 6, 2018 at 13:14 #11875

Han

When the problem started, were you working in an older version of ELAN? I mean, did the change in behavior co-occur with any of the updates you mention or did you update ELAN, QT and Java after the jumps started to happen?
If you right-click the video in ELAN and select “Player Info”, what does it say for the player framework? (You mention you updated QuickTime but maybe/probably that is not the player in use in ELAN?)
If you look into the log (View->View Log…) after a jump to the end of media, are there error or warning messages in the last few lines?

-Han

February 6, 2018 at 14:40 #11876

JS

The problem started after a month of not using ELAN. I worked with the 5.0 version where everything was okay. I haven’t opened the files for a month and out of nothing I have this problem with a jumping cursor.

I updated ELAN, QT, and Java after the jump started.

“Player info” says: “Java DirectShow Player”. However in the Preferences under “Platform OS”, I ran a test using “QuickTime for Java” and still have this same problem.

There is nothing called “error” but there are some “warnings” in the log file: https://ufile.io/m0rop

J.

February 7, 2018 at 12:08 #11877

Han

Thank you for the additional information.
Bottom line, I cannot explain how such a problem could suddenly appear with all variables unchanged: same ELAN version, same video files, same system (no updates) etc. I also don’t really know what you can do about it now.

I had another look into the code of the that player, the “Java DirectShow Player”, and I can’t find anything in our code anymore that could cause such a jump. I saw that you are using .avi files and when I tried with an .avi here myself, I couldn’t reproduce your problem, but noticed that some behavior is different with (my) .avi. When playing a selection, playback stops at the end of the selection but the ELAN play/pause button still shows the icon with the two vertical bars, indicating that ELAN did not detect that the native player stopped. I was able to repair that for a next version of ELAN, but I don’t think this will correct your problem.

I noticed in your log that you have ffdshow installed, there is an LAV splitter in the filter graph. It seems that some problems are related to the codecs in the graph. I don’t know if this would help but you could try what happens when you uninstall the ffdshow codecs. (But if these codecs were indeed already installed more than a month ago, this shouldn’t be it.)
Otherwise a possible solution could be to convert the files to a different format (but that might not be acceptable for some reasons).

February 7, 2018 at 14:45 #11878

JS

Dear Han,

Persistency pays off…I guess:)

I followed back on your comment about LAV splitter. It turned out that it was difficult to find it on the PC. It is a part of the K_Lite_Codec_Pack that I uninstalled to see what happens with the jumping cursor in ELAN.

It turns out that getting rid of the Codes solved a problem of the jumping cursor in all three ELAN versions (5.1; 5.0 and 4.9.4.) but only partially. A new problem appeared. After playing the selected part, the video stopped just before reaching the offset; it’s a matter of few milliseconds. I could re-listen the selection but I had to click twice on the button (and not once as it should be) simply because the cursor wasn’t aligned with the offset of the segment.

What I did to fix this problem is to install the standard K_Lite_Codec_Pack version (not basic or advanced version) once again on the computer. I ran my little experiment with three versions of ELAN and it looks good. The problem of re-playing selected parts is working flawlessly in all ELAN versions.

Hope, the problem with “Play selection” and the jumping cursors is gone forever.

Best,

Joanna

February 9, 2018 at 11:50 #11879

Han

Hi Joanna, I hope so too. The new problem you mention, the video stopping just before the end of the selection, is the one I observed too with my .avi file and this is the one that will be fixed in the next release.
This just for the record, you already solved your problem!

-Han

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.