Home Forums Software Recognizers Recognizers error through ELAN-Main class issue

Recognizers error through ELAN-Main class issue

This topic contains 6 replies, has 2 voices, and was last updated by  peace 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
Author Posts
Author Posts
September 18, 2017 at 17:06 #11683

peace

Using ELAN-5.0.0-beta on Windows, any attempt to test various recognizers (e.g.Standard Segmentation), fails, giving in the report the following error message:
Error: Could not find or load main class AvatechClamClient
Recognizer stopped; unexpected end of transmission.

I tried to use the specific folder where the file “AvatechClamClient.class” (…\ELAN 5.0.0-beta\extensions\clam-iais-standard-segmentation) resides as my elan project directory, but this did not help as well.

Any help will be appreciated, thank you all in advance!

September 19, 2017 at 13:06 #11685

Han

Hmm, I just tried several recognizers on my Windows machine and it just worked. So, I wonder what might be the difference. Did you make any changes to the directory structure of the ELAN installation folder or any changes to the included JRE (Java Runtime Environment)?

-Han

September 19, 2017 at 13:47 #11686

peace

Han thank you for the reply.

I had actually made changes to the installation directory, so I re-installed the ELAN-5.0.0-beta version in the default directory, confirmed the existence of jre folder inside the installation folder, retried the simple segmentation recognizer and unfortunately got the same Error about the main class.

September 19, 2017 at 16:37 #11690

Han

I don’t understand. Maybe you can try this: open the file recognizer.cmdi that is in the same standard segmentation folder in a text editor, look for the line that starts with
runWin=”java AvatechClamClient etc.
and insert an option so that the line starts as follows:
runWin=”java -XshowSettings AvatechClamClient etc.
Save the file, quit ELAN, launch again and try to run the recognizer again.
In the additional information under the Report button, what is the value of the property “user.dir”?

September 19, 2017 at 17:29 #11691

peace

Extra information by using the proposed option:
user.dir = C:\Program Files (x86)\ELAN 5.0.0-beta\extensions\clam-iais-standard-segmentation

In case you think this is an address/directory related issue, I can check on a Linux machine in a couple of days and get back if something goes wrong.

In any case, thank you for your help!

September 20, 2017 at 11:12 #11692

Han

Thanks for the information, that seems correct then. Indeed, the error message of the missing main class AvatechClamClient could have been caused the command “java AvatechClamClient” being executed in the wrong directory. But that is not the case apparently.
So, maybe the finding of the class is not the problem but the loading, but usually the error message would contain more details on why the class can’t be loaded.

September 20, 2017 at 11:30 #11693

peace

So Han, an update, on the issue:

I tested the recognizers on Ubuntu, everything is smooth!
So I can run some tests, and this is just fine for doing what I intended!

The issue per se, running recognizers on Windows 7, is still puzzling me, I looked all the provided information in the report by using the option -XshowSettings, I did not pinpoint anything disturbing.

In the near future, I will test on various existing Windows versions and get back with a new post.

Thank you!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.