Home Forums Software ELAN Save dialogue blocks file name?

Save dialogue blocks file name?

Tagged: , ,

This topic contains 2 replies, has 2 voices, and was last updated by  belew 1 year ago.

Viewing 3 posts - 1 through 3 (of 3 total)
Author Posts
Author Posts
January 25, 2018 at 01:18 #11853



Didn’t see this in existing topics, but apologies if it’s a duplicate question.

I just updated to ELAN 5.1 for OSX El Capitain, and now when I go to save a file, there’s a box reading “Save As (eaf)” which blocks the ability to see the file name text box. There doesn’t seem to be any way to move it, or to move the save dialogue, so that I can select the file name or see what I’m typing there. Here’s a screenshot: https://imgur.com/gmDcoET

I can get around it by selecting the tags box and shift-tabbing up, but it’s a bit annoying; anyone know of any fixes? Thanks much for any help!


January 26, 2018 at 09:36 #11856


Yes, this is annoying. This message box was introduced as a (temporary) workaround for the missing title bar, which was removed by Apple in macOS Sierra.
The title bar is especially relevant when opening a file with “missing” linked media files: the title bar shows (showed) which media file to locate.
The intention is to position the Save or Open dialog below the little message box but this doesn’t always work, depending on screen size or resolution (I guess).

Apart from your shift-tab workaround you could also resize the dialog e.g. on the right side and then resize it vertically from the top? This is annoying too, but maybe the next time the Save dialog will have the same size and location you gave it. This is attempted by the code, but also doesn’t always work.

All this has to do with ELAN’s attempt to show a “Mac native” Open and Save dialog, with the Search bar and Sidebar with Favorites etc. If you don’t usually use these elements of the dialog, you could switch to a “Java” Save and Open dialog by unticking the “Use Mac File Dialog” in the Platform/OS tab of Edit Preferences. Then you don’t have to get around these workarounds anymore.


January 26, 2018 at 20:04 #11861


Ah, I didn’t know about the option to switch to a Java dialog– that works great! Thanks for the fix.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.