Home Forums Software ELAN Waveform not showing in Elan on Ubuntu 18.04

Waveform not showing in Elan on Ubuntu 18.04

This topic contains 3 replies, has 2 voices, and was last updated by  Han 2 weeks, 1 day ago.

Viewing 4 posts - 1 through 4 (of 4 total)
Author Posts
Author Posts
July 3, 2019 at 13:44 #13035

sverhees

I’m using Elan on Ubuntu 18.04, and when I open different .WAV files it displays the following error instead of the waveform: Failed to create a WAV Reader::[filepath] (No such file or directory). At the same time, the sound is working fine, and the same files when opened in Elan on Windows do display a waveform.

July 4, 2019 at 09:07 #13036

Han

That is strange.
Do you notice anything special in the [filepath] as it is printed? The only thing I can think of is that maybe the filepath is treated slightly different for the WAV Reader than for the media player.
Do the messages in the log (View ->View Log… ) maybe add more information as to why the file is not found by the WAV Reader?

-Han

July 4, 2019 at 10:29 #13037

sverhees

The filepath seems fine. I tried opening files from different locations, and each time it shows the same error, with the correct file path followed by the statement that there is no such file or directory.

Logs show the following error message sent by ELAN:

Failed to load plugin ‘/home/samira/.openjfx/cache/11/libavplugin-ffmpeg-57.so’: libavformat.so.57: cannot open shared object file: No such file or directory

July 5, 2019 at 21:17 #13041

Han

The message about the plugin is, I believe, not related to the waveform.

The waveform is loaded / read by a few pure Java classes, no platform specific, “native” libraries involved. The sound you hear is probably produced by a VLC based player or a JavaFX media player. If you only have a wav file linked the sound comes from that same file, if you have video too, the sound might also be the audio track of the video file.
Why the waveform isn’t shown, while it works on Windows and (probably) can be played by the media player, remains a mystery to me.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.