LEXUS

for creating lexica

LEXUS manual

Katarzyna Wojtylak

Max Planck Institute for Psycholinguistics, Nijmegen, The Netherlands
June 2012
# Table of Contents

1. Introduction ................................................................................................................. 5  
   1.1. LEXUS .................................................................................................................. 5  
   1.2. Registration and login ......................................................................................... 6  
   1.3. Work flow ............................................................................................................ 6  
   1.4. LEXUS workspace ............................................................................................... 7  
2. Create lexica .............................................................................................................. 9  
   2.1. New lexicon ........................................................................................................ 9  
   2.2. Defining lexicon structure ................................................................................. 9  
      2.2.1. Schema Element Editor ............................................................................. 10  
      2.2.2. View Editor ................................................................................................. 12  
   2.3. Lexical entries ..................................................................................................... 18  
      2.3.1. Lexicon Editor ............................................................................................ 18  
      2.3.2. Adding new lexical entries ....................................................................... 18  
      2.3.3. Modifying lexical entries ......................................................................... 19  
   2.4. Adding multimedia to lexical entries ............................................................... 19  
3. Importing and exporting lexica from/to other formats ........................................... 22  
   3.1. Convert Toolbox files to LEXUS ..................................................................... 22  
   3.2. Importing LEXUS XML files .......................................................................... 22  
   3.3. Exporting lexica to XML ................................................................................. 23  
   3.4. Exporting lexica to PDF .................................................................................... 23  
4. Searching, filters and queries ................................................................................... 24  
   4.1. Search ................................................................................................................. 24  
      4.1.1. Ad Hoc Search ............................................................................................ 24  
      4.1.2. Queries ........................................................................................................ 25  
   4.2. Filters ................................................................................................................. 26  
      4.2.1. Creating filters ........................................................................................... 26  
      4.2.2. Using filters ............................................................................................... 27  
5. Characters and sorting ............................................................................................... 28  
   5.1. Using non-latin characters ............................................................................. 28  
   5.2. Sort orders .......................................................................................................... 28  
   5.3. Creating sort orders ......................................................................................... 28  
   5.4. Applying sort orders ....................................................................................... 29  
6. Access rights ............................................................................................................ 30  
7. ViCoS ....................................................................................................................... 31
Chapter 1. Introduction

1.1. LEXUS

LEXUS is a web-based lexicon tool developed by the The Language Archive at the Max Planck Institute for Psycholinguistics, Nijmegen, The Netherlands (MPI). It is targeted at linguists doing language documentation or working with language corpora.

In LEXUS users may create lexica in online (private) workspaces and share lexica with other users either on a read-only basis or by assigning edit rights. Since LEXUS is web-based this sharing functionality allows a group of users to collaboratively create a lexicon from different places in the world, or to share lexica amongst linguistic researchers and speech community members.

LEXUS allows you to create lexica or import them from other formats (such as Toolbox). LEXUS is not just another lexicon tool: LEXUS offers the possibility to visualize language through the import of multimedia. There are various types of multimedia that can be linked to the lexical entries (i.e. images, video/audio files and webpages). For the DoBeS projects, MPI research and for research from third parties, data is stored in the digital archive for linguistic resources housed at the MPI. The archive is accessible via the Internet, and is organized in a structured manner by describing and contextualizing the data with the IMDI/CMDI metadata set. Lexical entries in LEXUS can be linked to domains and resources from this archive.

Lexicography in general is a domain in which uniformity and interoperability is rarely met. Depending on the purpose and tools used, various terminologies, structures and formats have been adopted. This makes cross lexica search, merging, linking and comparison extremely difficult. The Lexical Markup Framework (LMF) is an attempt at putting an end to this problem. LMF is an abstract model for the creation of customized lexica that are defined following the recommendations of the ISO/TC 37/SC 4 group on the standardization of linguistic terminology. LEXUS allows you to create purpose-specific and tailor-made lexicia encouraging at same time the LMF-based comparability and interoperability with other resources. More information on Lexical Markup Framework can be obtained from the LMF web site [http://www.lexicalmarkupframework.org/].

For new lexica, the structure of a LEXUS lexicon is predefined according to a template chosen by the user when the lexicon is created. The default and most basic template follows the schema given in Figure 1.1:

![Lexicon structure](image)

Figure 1.1. The default lexicon structure in LEXUS

Each of the elements in the schema can be expanded according to the wishes of the creator. Basically there are two ways of elaborating on such a model. You can add both a data container (which has the function of a folder) and a data category (which is a sheet to store relevant linguistic information). The lexicon structure is a hierarchy, in which data categories are placed inside data containers. The former ones are used in order to group elements that have something in common.

Form and Sense are the two most basic data containers. A number of other more specific data containers can be underpinned to them, which, in turn, can include other sub-containers. The goal is to store the data categories under the data containers as it is the data categories that encompass the lexical information of an
entry. It is up to the user to define the structure of the lexicon and in principle there are no restrictions to it. In Figure 1.2 we show a simple example of such a structure.

![Lexicon structure diagram]

**Figure 1.2. An example of a user defined LEXUS structure**

Together with LEXUS comes ViCoS - a tool for visualizing conceptual spaces. With ViCoS you may extend your lexicon with a set of relations between lexical entries or between specific data category labels within the lexical entries. ViCoS thus allows the creation of a semantic network and the navigation through this network. Since ViCoS also allows the creation of user/lexicon-specific types of relations, the network, which in this way is created, goes beyond the semantic level onto the cultural one given that conceptual spaces show words/attributes within the cultural context. For more information on ViCoS see either the Chapter 7 or the TLA webpage [http://tla.mpi.nl/tools/tla-tools/lexus/vicos].

For the best functioning of LEXUS and ViCoS, we recommend to use the newest version of the Mozilla Firefox browser (with a minimum screen resolution of 1280 x 1024) and the latest Flash Player plug in.

1.2. Registration and login

In LEXUS users need a workspace where the lexica are stored and where they can be shared with other users. To get this workspace, users have to register first. For now, the registration is not automatic. Therefore, in order to get a workspace with a user name and password, send us an e-mail at lexus@mpi.nl [mailto:lexus@mpi.nl].

1.3. Work flow

LEXUS is based on the principle of interaction of three major program components: 1. Workspace, 2. Schema and View Editor and 3. Lexicon Editor. These elements are dependent on each other and will not work properly until the interaction of these components is secured. For this reason, it is important to follow the general work flow when working with LEXUS:

1. [In the Workspace module]: create new lexicon/import a lexicon,

2. [In the Schema and View Editor module]: define the structure of the lexicon/make sure that the structure of the imported lexicon has been kept,
3. [In the Schema and View Editor module]: define the entry list view and the lexical entry view (optional default views are already provided),

4. [In the Lexicon Editor module]: add new entries and media,

5. [In the Workspace module]: define and apply the sort orders,

8. [Throughout the modules]: other functionalities (e.g. queries, filters, ad hoc search).

A LEXUS A4 guide (basic description of Lexus workflow and examples) is available online at the TLA website [http://tla.mpi.nl/tools/tla-tools/lexus].

1.4. LEXUS workspace

Once you have logged in, you will be directed to your LEXUS workspace. The workspace opens by default with the left frame in the Lexica tab (Figure 1.3), in which all the lexica available to you are listed in alphabetical order. The lexica can include lexica from other workspaces for which you have read and/or edit rights. These so called 'shared' lexica are indicated with an icon of a hand holding a blue book. Lexica for which you are the owner are indicated with a blue book icon.

When one of the lexica is selected, the Lexicon tab in the right frame displays information like Name, Description and Notes. In the other tabs, i.e. Readers and Writers, you can define the access rights for other LEXUS users for any of your lexica (See Chapter 6).

Figure 1.3. LEXUS workspace

The second tab of the left frame is Sort orders. It shows the sort orders that have been created within the workspace. In LEXUS, sort orders are used to sort entries of lexica. Their structure consists of various sort rules, each one containing two fields: Start Letters and Characters that by default have been predefined with the Latin alphabet. The position of these sort rules in the sort order list determines the sorting position of the lexical entries. The position of these elements in the sort order list determines the sorting position of the lexical entries. To add a new sort order click on the icon under the Available Sort Orders frame. Once a sort order is selected, you may further edit and modify it in the right pane. The sort orders can be used throughout all the available lexica in the workspace (See Section 5.2).

The third tab in the left frame is Search. In the window under the tab you may specify queries over one or multiple lexica (Section 4.1). Queries are predefined searches which can be stored and re-used later. Alternatively you can use the Ad hoc search to do a simple search using key words (See Section 4.1).
In the top frame of the workspace, you will find the LEXUS main menu: File, Switch to, and Help. Main options of File in the Workspace module are: Save, Convert Toolbox files to LEXUS, Import LEXUS XML and Log out. In the Schema and View Editor module, Convert Toolbox files to LEXUS and Import LEXUS XML are disabled. In the Lexicon Editor module, additionally two more options are available: Export to PDF and Export to XML. The second option of the LEXUS main menu, Switch to, allows you to switch between the different areas of LEXUS and, in the Workspace module, to access ViCoS (Chapter 7).

One of the functions under Help is redirecting to the online manual. Moreover, in the Help menu, you can also use the Activate Unicode Input option. If you run into problems when inputting Unicode characters, you can try to upgrade the version of the Flash Player. If this is not possible, use the Activate Unicode Input option. The LEXUS icon on the upper left holds information on the LEXUS version. Please, check the version number with the version number of the manual you are using.

In the following chapters, it will be shown how you can (1) Create new lexica (Section 2.1) (2) Add and modify lexical entries (Section 2.3.2) (3) Import lexica from Toolbox and import XML formatted lexica (Chapter 3), (4) Search through one or multiple lexica (Chapter 4) by creating Filters/Queries (Section 4.2), (5) Create and apply sort orders (Chapter 5) and (6) grant Access rights to other registered LEXUS users (Chapter 6).
Chapter 2. Create lexica

2.1. New lexicon

New lexica are created in the LEXUS Workspace module (Section 1.4). In the Lexica tab, click the + icon. This will open a pop up where you can specify the name of the new lexicon and, optionally, give a description to that lexicon. Moreover, you can also select a lexicon template (which will be used for your new lexicon schema and views) and add any necessary comments in the Note field (Figure 2.1).

![New lexicon pop up](image)

Figure 2.1. New lexicon pop up

Templates are different predefined structures for new lexica based on the LMF. At this moment LEXUS provides you with the Default Template but soon more templates will be made available.

Once you have clicked Save, the lexicon will be created and you will be automatically moved from your workspace to the Schema and View Editor in which you will create a structure for your new lexicon. You can always go back to Workspace by selecting in the top menu Switch To >Workspace. Also, when you select your lexicon in the list of the available lexica, you can modify its name, description and notes.

If you want to remove any of the lexica from the lexica list, select it in the list in the Lexica tab (in the Workspace module) and click the - button. If you remove a large lexicon, it might take a while until the lexicon has been fully removed.

2.2. Defining lexicon structure

In LEXUS lexica consist of their structure and content. You will always need to define a structure for your lexicon before you can add content to it (i.e. lexical entries). The default structure of a new lexicon is a basic LMF structure and consists of the LexicalEntry data component which, in its turn consists of two data containers: Form (with the by default introduced data category Lexeme) and Sense (see Figure 1.1). As explained before, data containers are holders for data categories, which are in turn the actual value holders. You could compare this to a computer file system. The data containers are the folders and the data categories are the files, which hold their content. It is up to you to decide what you would want the structure of your lexicon to be. Group data categories which relate to the form of the lexical entry under Form (e.g. orthography, image, plural markers etc.) and data categories related to meaning under Sense (e.g. gloss, definition). It is possible to move the elements within the structure (but only within the same data container). To move the elements you need to drag and drop them into a desired location in the tree.
For users with no previous experience with LMF we recommend to visit the LMF web site [http://www.lexicalmarkupframework.org/].

2.2.1. Schema Element Editor

Once you have saved your new lexicon, you will be automatically redirected to the Schema and View Editor where the structure of your lexicon is yet to be defined (you can also access it by following Switch To >Schema and View Editor or double-clicking on the lexicon while holding the Shift button).

The Schema Element Editor window consists of two frames. The left frame (called Lexicon structure) shows the default structure of your new lexicon that consists of two data containers: Form (with the Lexeme data category) and Sense. The right frame consists of two tabs: Schema element tab and View Editor tab. The Schema Element tab displays information on the selected element of the schema in the left frame. The information contains the name of the element, a description and specifies whether:

(1) the element is mandatory for lexical entries of the lexicon,

(2) multiples of this element are allowed.

In the View Editor tab you can create various views for your lexicon and the lexical entry display. As explained above, the structure of your new lexicon consists now only of two data containers and one data category. However, it will need to be extended according to the requirements of your lexicon. To add new elements, select e.g. Form and click on the + icon below the left frame under the Lexicon Structure. A pop up window, New Schema Element, will appear in which you will be able to specify whether you wish to create a data container or data category. Mark data category and add a name and a description. After having done it, click OK. A new data category item will be created under Form (Figure 2.3).
In the same way you can create data containers in your lexicon. Following the simple folder - file analogy, it is possible to create data containers under other data containers (just like a simple folder-subfolder structure), but it is not allowed to create data categories under other data categories.

To modify an existing item in the structure, select the element in the lexicon structure, and see the Schema Element tab in the right frame. You can modify all the previously added information (i.e. Name, Description, Admin Info (i.e. any administrative info you might want to add) and whether the element should be mandatory or/and allow multiples). Moreover, you can also select a sort order for that given element and write a note. However, in LEXUS the application of the sort order for the structural elements should be done at the very end of the lexicon creation (see Section 1.3).

In case of data categories, you may decide to change from the user-defined type to the predefined data categories: either the Toolbox MDF categories or the ISO 12620 registry (ISOcat). For further information about ISOcat see the ISO Data Category Registry website [http://www.isocat.org/]. While changing to a Toolbox-defined data category is useful in those cases where you need maximum interoperability between the newly created lexicon and lexica in your workspace which were imported from the Toolbox application, changing to ISO 12620 data categories enhances interoperability and standardizes your lexicon to a wider accepted conceptual format.

(1) To change to Toolbox MDF categories, select a data category element in the lexicon structure in the left frame. In the right frame, under Registry click Toolbox MDF. Select the Toolbox data category from the list. Note that the description field will fill with information on the Toolbox element.
To change to an ISO 12620 element, select a data category element in the lexicon structure in the left frame. In the right frame, under Type click 'ISO12620'. Fill in the name of the data category in the search box, select in which repositories you want to search and select one of the elements from the search results (see Figure 2.5). In this example we replace the user created data category by the ISOcat data category 'word'. A description of the data category is given in the search result list. For more detailed information on the data category a link to the ISOcat web site is given under the magnifier glass right of the search results.

2.2.2. View Editor

In LEXUS the lexical entries are displayed according to the views that you can create. By default there are two views available, List View and Lexical Entry View. According to the requirements of your lexicon,
they can be easily modified. LEXUS uses the former view to display the word list of your lexicon and the latter one to show the graphical representation of your lexical entry.

Once the structure of the lexicon has been created (and before you start to add lexical entries), in the Schema and View Editor select the View Editor tab in the right frame. You will see the two previously mentioned default views: List View and Lexical Entry View which, by default, are assigned to the list and the entry views (in the Apply View frame).

![Figure 2.6. The View Editor in the Schema and View Editor](image)

While creating a view, you can always click on the Help button in the right frame. Moreover, you can also check the Tips box. If you hover over the elements in the view structure, you will get information of what they are.

### 2.2.2.1. Defining the List View

You can either modify the existing List View or create a new one. In this section we will guide you and help you create a new view. Once you know how to do that, you will be able to modify the default List View (this is optional).

Click on the + icon under the window with Available Views and give your new view a name and a description. First, you should decide which data categories from the structure of the lexicon should be used to represent the lexical entries in the word list. Usually the data category Lexeme is used for this and that is why Lexeme is already part of the List View by default.
Figure 2.7. Defining the List View in the Schema and View Editor

To add more elements, drag a data category (as *Lexeme*) from the tree into the *Structure Editor* window under *View*. It will appear under it. In practice it means that now in the word list of your lexicon the content of *Lexeme* will be displayed.

You can now change the style properties of this item: font size, font type, colour, bold, italic etc. Drag the *Decorator* element on the right to the element *View* in the *Structure Editor* and drop it. It will appear below *Lexeme*. Drag and drop *Lexeme* into the *Decorator*. The *Decorator* will now have a new name: `<Lexeme>`. Double click it and choose a new styling method. Be aware of the *Inherited* function. If *Inherited* is chosen, the elements will be styled according either to the default style or the style of the element that is hierarchically above them in the lexicon structure. The *Display as Separate Block* function allows the full block inside the *Decorator* to be shown in a separate line.

Figure 2.8. View elements styling pop up

For those who know CSS, it is worth to mention that the view can be styled by using CSS as well. Double click on the data category element in the tree and mark the option *Define CSS class*. Name the class that you will be using for this element and click on *OK*.

Figure 2.9. Defining the CSS class
Create lexica

The element will change its name. Go to the Style Editor tab and select Add styles for classes.

Figure 2.10. Defining the CSS styling in the Style Editor

If you need help with defining the CSS class, click on the button Help with Styles which will help you to style lexical entries with CSS.

In the same manner you can add to / modify data categories of the List view and change their layout. Be careful not to add too many data categories to the view, since this will create a chaotic view in the word list. Moreover, the order in which you add data categories to the list view should follow the structure of the lexicon. E.g. If your structure consists of a lexeme with a sub-structure, followed by a sub-entry with a sub-structure and you wish to display the lexeme with its gloss and the sub-entry with its gloss, insert them in the following order: Lexeme, Gloss, Sub-Entry, Sub-Entry-Gloss. To delete an element from the tree structure, select it and press the Delete button on your keyboard.

After you have created/modified your view, make sure that it is selected in the drop-down menu under Apply Views > List View (below the available views).

Figure 2.11. The Apply Views window

Note that the List View and Lexical Entry View have to be different. Save the changes (File>Save) and go to the Lexicon Editor module.

The List View that you have created has now been applied to your lexicon word list. (Note that, as shown above, new lexica are created with one example lexical entry, Lexeme). If you have not created any lexical entries yet, you will need to do that first to see the results (Section 2.3).

If you want to delete a view, select it and click on the icon. However, be aware that it is not possible to remove assigned views that are used at the moment.

2.2.2.2. Defining the Lexical Entry View

After you have defined your list view (either your own or the default one), you can also define the Lexical Entry View (again, you can either create your own or modify the existing one). The Lexical Entry View is
the representation of the lexical entry on the screen after it has been selected from the word list. This means it is a far more elaborate view of the lexical entry.

![Image](image.png)

**Figure 2.12. Defining the Lexical Entry View in the Schema and View Editor**

In comparison to the *List View*, the structure of the *Lexical Entry View* is usually longer. Therefore, you are expected to add many data categories to the view. The previous section shows how to create and modify that (see Section 2.2.2.1).

The *views tree* in the *Schema Editor* allows you:

1. to copy data categories from the *structure tree* to it. In this operation the dragged data category will be placed as the last child of the element under the drop location,

![Image](image.png)

**Figure 2.13. Copying data categories from the structure tree**

2. to copy visual elements from the right side list to it (e.g., *Decorators, Multipliers, Line breaks*). Again, in this operation the selected element will be placed as the last child of the element under the drop location,
Moreover, for the *Lexical Entry View* it is possible to create Tables in which LEXUS will display all the data categories you want. Tables are mainly used to structure the layout of visual elements. Here follows an example of a simple tree structure with a table:

The result of the view structure presented above, in the *Lexical Entry View* (the *Lexicon Editor* module) is the following:

Also, you can apply *Multipliers* (allows you to replicate visual structures for each occurrence of the same data category in a certain lexical entry), *Horizontal lines* (inserts a horizontal line in whatever position), *Line breaks* (inserts a line break in whatever position) and *Text* (allows to insert any text value).
2.3. Lexical entries

After the structure of the lexicon has been created (Section 2.2) and after the initial views have been defined (Section 2.2.2.1), you can start adding the lexical entries. To do this, double click on the lexicon in the list in the Workspace to switch to the Lexicon editor (you can also use the Switch to menu in the top frame after having selected your lexicon).

2.3.1. Lexicon Editor

The Lexicon Editor module consists of two frames (see Figure 2.18). The left frame is composed of the Lexicon and Filters tabs.

In the Lexicon tab you see the word list (initially, by default, it consists of one example entry "lexeme") . Above the word list there is a number of options that you may choose from:

1. you can choose to display the lexicon by using the drop down list in the box <switch lexicon>
2. you can choose a selection of the words, based on initial character by selecting the character from the drop down list <grapheme>
3. you can display a selection of the lexical entries by selecting a filter (Section 4.2 )
4. you may switch to the structure view of the selected lexical entry (as opposed to the list view),
5. you can look for particular character sequences in the search window (moreover, you can also specify the character capitalization (aBc),
6. you can also go back to the whole entry list of your lexicon by clicking All.

In the right frame there are two tabs: Lexical Entry and Lexical Entry View. The first one displays the lexical entry in a configuration as defined in the Lexical Entry View Editor (see Section 2.2.2.2). The second one displays the values of each data category of the lexical entry in a structured manner.

Figure 2.18. Options of the Lexicon tab of the Lexicon Editor

2.3.2. Adding new lexical entries

To add a new lexical entry, click on the icon below the word list. A new empty entry will appear in the word list. In the right frame the Lexical entry tab gives you the option to add values for the data categories in the boxes.
2.3.3. Modifying lexical entries

In the word list, select the entry that you wish to edit, in the right frame open the Lexical Entry tab and adjust the values. To save the changes, either select File > Save from the menu in the top frame or move away from the entry (you will see a message asking whether to save the changes).

Besides changing the values of the lexical entries, you might also want to add data categories or data containers. Although the structure of the lexical entry is always consistent with the structure defined for the lexicon (Section 2.2), when the Multiples allowed check box has been selected, elements can appear more than once in one lexical entry (e.g. a lexical entry can have two data categories "Gloss" - the original "Gloss" and its copy). This option is useful to deal with homonymy and the like. The Add features function allows you to add those fields that are not mandatory as they do not show up by default.

In the word list select a lexical entry and switch to Structure view. Select a data container to which you want to add a new element from the Add Features option at the bottom of the frame (Figure 2.19) and the chosen element will be added to the structure. Save the view.

![Figure 2.19. Add features in the Switch to Structure View frame](image)

As it was the case for the view trees in the Schema and View Editor module (described in Section 2.2.2.2), it is also possible for the structure view in the Lexicon Editor module, to move and copy the elements within the same parent in the structure (to move the elements you need to drag and drop them into a desired location in the tree and to copy you have to move them after having selected them while holding the Ctrl button (Cmd button on Apple)).

In the right frame of the Lexicon Editor (Lexical Entry), you will see a new data category box added to the entry.

2.4. Adding multimedia to lexical entries

In LEXUS you may add three types of multimedia: images, sound files and video files. It is wise to create a separate data category for the multimedia in the lexicon structure. An example of this is given in Figure 2.20, where a Multimedia container (under LexicalEntry > Form > Multi Media) with two data categories: Image and Video, is located under Form. How to add data categories and components to your structure is explained in Section 2.2.
Figure 2.20. Multimedia in the lexicon structure

To add multimedia to the lexical entry, go to the Lexicon Editor module and select any lexical entry from the word list. In the right frame select the Lexical Entry tab and move to the data category box where you want to add the multimedia.

Figure 2.21. Importing a picture in LEXUS

Next, in the lower part of the right frame, select the Multimedia tab and click Import. LEXUS prompts you to choose between uploading the media from your local computer into the LEXUS database or create a link to media stored in the MPI archive for linguistic resources.
To upload from your local computer, click Select Resource and browse for an image, a sound or a video file. After uploading, save it the top frame menu: File > Save. If you have defined the lexical entry view such that it will display the value of the media data category, it will show the media in a boxed frame which includes the caption (defined in the datacategory text value). The image is not scalable, but has a standard width.

Note that since LEXUS allows to add multimedia to every data category in the structure, you do not need to create a separate data category for the multimedia. You could also add the image to e.g. the headword data category. In the lexical entry view this would result in a box around the headword and the media file.

To link multimedia stored in the MPI archive, select Archive in the Import Resource pop-up. LEXUS prompts you for the internal node ID in the MPI archive.

To find this node ID, open a new tab in your internet browser and open the MPI archive at http://corpus1.mpi.nl. In the corpus tree browse to the node where you want to link to, e.g. an ELAN annotation file. Click on the resource in the tree and from the right frame copy the value of the internal node ID (e.g. MPI600401#). Note that for some type of resources the information does not show up immediately. In this case, chose Create bookmark from the context menu to have it displayed. Copy this ID in the Get Resource box in LEXUS. When you have selected an ELAN file, LEXUS will also prompt you to feed the start time and end time of the fragment you wish to link to link to your data category. When you ignore this, LEXUS will start from the beginning of the file. After uploading, save it via File > Save.
Chapter 3. Importing and exporting lexica from/to other formats

3.1. Convert Toolbox files to LEXUS

To convert your Toolbox files that you already have, in the Workspace module select File > Convert Toolbox files to LEXUS. A pop up will appear in which you can select files to be converted into the LEXUS format (XML).

![Figure 3.1. Converting Toolbox files to LEXUS](image)

Converting can take time depending on the size of the lexicon. You will see the progress bar during the process. You can always cancel the convert process by clicking on Cancel.

Once the convert process is finished, you are able to download a .zip file that you have to unzip in order to import it into LEXUS (as described in Section 3.2). Click on Start to begin with downloading the .zip files.

![Figure 3.2. The pop up window with the converted files ready to download](image)

There is a From Toolbox to LEXUS manual is available online at the TLA website [http://tla.mpi.nl/tools/tla-tools/lexus].

3.2. Importing LEXUS XML files

In order to import an XML lexicon, LEXUS requires two XML data files (which, when unzipped, are the result of the above described convert process). To import these files into LEXUS, select File > Import XML. Select first a file containing the structure of the lexicon and later a file containing the lexicon data.
3.3. Exporting lexica to XML

Lexica can be exported to XML. To do this, in the Lexicon Editor module, open the lexicon for which you want to create an XML export file and select Export XML under File. A dialogue frame opens where you specify the name of the XML export file and its folder location. Once the download is complete, you will get an alert message. If you want to edit the contents of the exported XML file or create an XML schema file for the lexicon, use an external XML editor.

3.4. Exporting lexica to PDF

Lexica can be exported to the PDF format. To do that you need to have a new view defined in the Schema and View Editor that will be used as the PDF layout for your lexicon. Once you have created it, open your lexicon in the Lexicon Editor module and in the top menu option File, click Export to PDF and select the previously defined view. The PDF file will open in a new tab of your browser.
Chapter 4. Searching, filters and queries

LEXUS allows you to filter and search throughout your lexica. While searching (i.e. queries and the ad hoc search functionality) takes place at the Workspace level, filtering is at the Lexicon Editor level.

4.1. Search

LEXUS provides search functionalities for searching all the lexica within your own workspace. This includes those lexica for which you have been granted rights (i.e. shared lexica) but which originate from other workspaces (users). You can search in two ways: through the Ad Hoc Search and through the Query Builder.

(1) Use the Ad Hoc Search to do a relatively simple search in only one lexicon and in one data category. Ad hoc search is available in the Search tab of the Workspace module.

(2) With the Query Search you can define complex search queries over multiple lexica and in more than one data category. The queries can be saved and re-used. The query can be defined and run in the Search tab in the Workspace module.

4.1.1. Ad Hoc Search

In the Ad Hoc Search, you need to specify the following:

(1) the lexicon in which you want to search,

(2) the data category,

(3) the search condition (is/contains/begins with/ends with),

(4) the negation of the search condition (is not, contains not...)

(5) the search string,

(6) whether the search should be 'case (in)sensitive'.

The Ad Hoc Search window is shown in Figure 4.1.

Figure 4.1. The Ad Hoc Search
Moreover, the **Ad Hoc Search** offers four other ways of searching when leave the search string ([5]) is left empty:

1. if you use the condition *is*, you search for all the lexical entries which have the specified data category with an empty value,
2. if you use the condition *is* and negate it by checking the NOT box ([4]), you search for all the lexical entries which have the specified data category with whatever not empty value,
3. if you use the condition *contains*, you search for all the lexical entries which have the specified data category,
4. if you use the condition *contains* and negate it, you search for all the lexical entries which do not have the specified data category.

The other conditions (i.e. *begins with* and *ends with*) do not work when the search string is left empty.

**4.1.2. Queries**

With the query builder you can create complex searches across multiple lexica. To create a query, go to the **Search** tab in the top frame of the **Workspace** module. In the **Queries** tab, in the left frame you will find a list of the queries available in the **Workspace**. Initially this list is empty. Click on the icon to create a new query. In the pop up window, add a name for the query and if you want also add a description. Subsequently, define the lexicon for the query and the search condition(s). Once you save it, your new query will appear in the query list. Select it and click on the magnifying glass below the left frame to run it. The results of the query will be shown in a new tab.

![Figure 4.2. An example of a query](image)

You can expand your query by adding more constraints to it. If you want to define a second constraint of your query, decide first what its relation is going to be with the first query constraint: either the **AND relation** or the **OR relation**.

In case you want the **AND relation**: select the data category node of the query and click the icon. Specify the data category and a search condition. The second query constraints will now be sub-ordinate to
the first one (in the query tree, the second constraint will be the child of the first one since it will select the smaller parts of the results set returned by its parent constraint).

In case you want the OR relation: select the lexicon node of the query, and click the icon. Specify the data category and a search condition. The new condition will now be co-ordinate to the first one (both constraints will be siblings to each other in the query tree).

![Query editor](image)

**Figure 4.3. The AND and OR relations in the tree structure**

By adding more lexica to your query, you can also search in multiple lexica at the same time.

Save your created query either from the File> Save menu or by moving away from it in the query list.

To delete a whole query or to remove one of its elements, select it and click on the icon below the selected element frame.

### 4.2. Filters

With LEXUS you may also create filters within lexica. For instance, you may create a filter which filters out all the lexical entries which have 'noun' as a value for the 'part of speech' data category. Applying this filter on the word list of a lexicon, will result in a word list of nouns only. Likewise, you can create thematic filters (by selecting only those entries from your word list which e.g. represent animals).

#### 4.2.1. Creating filters

Since filters are specific for a certain lexicon, you define the filter in the Lexicon Editor module, under the Filters tab. The process of creating a filter is similar to the process of creating a query, with the sole exception that you do not select a lexicon (since it is already predefined). Please, check the Queries section.
4.2.2. Using filters

The filters are available from the <filter> option (Figure 4.5) just above the word list in the Lexicon tab of the Lexicon Editor. Select the filter from the drop down list and the word list will show the lexical entries that match the filter criteria.

Figure 4.4. The filter builder pop up

Figure 4.5. Selecting filters in the Lexicon tab
Chapter 5. Characters and sorting

5.1. Using non-latin characters

The values of the data categories can be entered in non-latin characters.

For Windows 7 users: first you need to add the language that you wish to use. To do this, open the Control Panel, select Clock, Language, and Region and open Change keyboards or other input methods. Choose Change Keyboards and Add the required language. On your taskbar you can switch now between input languages. If you are using a different operating system, or if the language you wish to use is not in the drop down list of available languages, you should check how to add languages to the input languages.

If you have problems with entering non-latin characters in LEXUS, upgrade your browser and the Flash Player plug in. If this does not help, select Activate Unicode Input under Help in the top menu. The input boxes should turn gray upon selection after this option has been selected.

5.2. Sort orders

In LEXUS sort orders are used to sort entries of your lexicon. Their structure consists of sort rules, each one composed by two elements: Start Letter and Character that by default have been predefined with the Latin alphabet. The position of a rule in the rules list determines the sorting position. Start Letter is the symbol used to represent all the "characters" presented in the Characters column of a given rule. It determines where the entries starting with the characters specified in the Characters column will be placed.

In LEXUS you can create sort orders which are language specific. For every data category you can indicate which sort order you want to apply to it. In general, the process of sorting consists of two steps: first create a sort order and then apply it to a data category. This operation takes place in the Schema and View Editor.

5.3. Creating sort orders

Sort orders are created at the Workspace level, so that they can be used on any data category in any of the lexica in the workspace. In the left frame of the Workspace select the Sort orders tab. In the list in the left frame you will see all the sort orders available for the workspace (initially this list is empty). To create a new sort order, click the icon and, in the pop-up, give it a name and a description.

When you select the new sort order in the left frame, the right frame Sort Order Editor becomes active: the name and the description of the sort orders are heading a table which consists of two columns, Start Letter and Character. To adjust your sort order and its rules, you can:

1. Remove rules: select any rule, click the icon and remove them one by one. You can also press the icon to remove all rules at once.

2. Define/modify the rules: select any rule in the left column. Give it a Start Letter (e.g. 'a') by double clicking the 'Start Letter' column. Define the list of characters that you would like to be sorted under the 'a' (e.g. AάΆΆΆΆΆΆΆΆΆΆ) and add this list in the right column. Beware of the order in this list, LEXUS will prioritize (first in the list comes first in the sort order).

3. Using combined characters as Characters: when you are using a combination of e.g. '-' and 'a' (that is '-'a') and you would like it to be sorted under 'a' (the Start Letter column), then you should put this combination in square brackets ('-a') in the list in the Characters column. An example of this is shown in Figure 5.1
Using combined characters as Start Letters: in some languages a character exists only as a combination of two. For instance, in Dutch there is a character 'ij' that combine the 'i' and the 'j'. To be able to enter this character as a start letter, move to the location in the alphabet where you want to add a character (e.g. between 'x' and 'y') and click the button. An empty line appears where you can add the new rule. There is no need to use the square brackets in the Start Letter column. See the example given in Figure 5.2.

In LEXUS it is possible to enter very complex sets of characters. For example, the Iwaidja alphabet contains a combination of ‘^(rt)a’ which should be sorted under ‘a’. Because the ‘^’ symbol is used internally in LEXUS, the combination needs to be formatted as [\^\(rt\)a] in the sort order table. For questions on special sort orders send an e-mail to us at lexus@mpi.nl.

After you have created a sort order, make sure you either save it through File>Save or by moving away from it and confirming the save in the alert pop up window.

There is a special Sort Order Help menu in LEXUS. Once you have a sort order selected in the Sort Orders tab in the Workspace module, click on Help. A help menu will appear where you can find examples of sort orders and further explanation.

5.4. Applying sort orders

Sort orders are stored at the Workspace level. They should be applied to the data category which is first defined in the Schema and View Editor module. The sort order should be defined for the Word list view (Section 2.2.2.1) (the sort order will define the placement of words in the word list in the Lexicon Editor). In the Schema and View editor, go to the Schema element tab, and in the tree in the left frame, select the data category to which you want to apply a sort order. Once the data category is selected, in the bottom part of the right frame select a sort order. Save through File> Save.
Chapter 6. Access rights

LEXUS allows you to share your lexica with other registered LEXUS users. You can either assign them Read Rights only, which will enable the user to view the lexicon in his or her workspace, or you can grant Write Rights to other users. This means that this user can open the lexicon in his or her workspace and make changes to it.

To grant rights for a lexicon, move to the Workspace module and select the lexicon from the Available Lexica list. In the right frame select the Readers tab (or the Writers tab in case you want to grant writing rights). The Readers window shows you the users which are currently allowed to read this lexicon. Load users in LEXUS users to see all registered LEXUS users. Select the user(s) that you wish to grant rights to and drag them to the Readers window (Figure 6.1).

Note that lexica that have their origin in an external workspace, have a different icon than the ones created in the workspace and, only the lexicon owner can change their read/write rights.

![Figure 6.1. Assigning the readers rights to other users](image-url)
Chapter 7. ViCoS

ViCoS (Visualizing Conceptual Spaces) is an extension of LEXUS. It allows users to complement lexical spaces (as created by LEXUS) with ontological spaces. With ViCoS, users can define concepts they judge culturally relevant, and connect them to other concepts via a multitude of (user-definable) relation types. All concepts are anchored in the language to express them, and links can be established to objects in the multimedia archive to further describe them. The resulting conceptual space thus adds a new dimension to language documentation.

ViCoS is inextricably linked to LEXUS in that it draws on your lexical material that you have assembled in LEXUS to create a network of conceptual spaces. You can work on all the lexica that you have in LEXUS creating conceptual links between entries within a particular lexicon as well as linking entries from different lexica in your workspace. Importantly, everything that you create in ViCoS is created on the LEXUS data. ViCoS, however, does not modify your lexica in LEXUS in any way. In that sense the structures created in ViCoS are independent conceptual spaces. Still, ViCoS allows users to easily switch between the conceptual space that it embodies and the lexical space of LEXUS which makes the study of language and culture more integrated.

To switch from LEXUS to ViCoS, use the top menu option **Switch to**> **VICOS**.

ViCoS is currently not actively developed by the TLA.

The ViCoS manual can be found on the TLA webpage [http://tla.mpi.nl/tools/tla-tools/lexus/vicos].